Integrar drivers en un CD de instalacion de Windows XP

Martes, 23 de Octubre de 2007
Escrito por Neodian a las 10:00
158 comentarios

Actualizacion 10/06/08

El nuevo Windows uE SP3 ya tiene incluidos los drivers para la mayoria de controladoras de discos duros sata y raid. Podeis pasaros por aqui para ver la novedades y acceder a la descarga via emule.

Un lector me ha preguntado que como podia hacer para integrar los drivers de la controladora sata de su portatil en la instalacion de Windows XP de tal forma que pudiese instalar dicho sistema operativo. La respuesta ha sido un poco extensa asi que he decidido convertirla en un articulo puesto que ya lo habia pensado con anterioridad.

Veamos, ya conocemos el problema, compramos un portatil nuevo con un disco duro sata y trae windows vista, bien queremos meter el xp, que pasa, metemos el cd iniciamos la instalacion y…no hay disco duro. Lo suyo seria descargar los drivers de la pagina web del fabricante meterlos en un disquete y al iniciar la instalacion pulsar una tecla cuando lo indique, problema, el portatil es nuevo y como todos los nuevos NO TIENE DISQUETERA!!!!(cosa que me parece estupenda). Que hacemos, pues o conseguimos una disquetera externa o tenemos que currarnos un cd de instalacion de windows xp modificado que tenga los drivers incorporados, esto a dia de hoy es muy sencillo, vamos a usar un programita muy util(y freeware) llamado nlite. Pero antes veamos que necesitamos:

Los drivers para xp de todo lo que queramos instalar, nosotros queremos los de la controladora sata pero de paso meteremos los de la grafica y el sonido y asi ya no tendremos que instalarlo despues manualmente. Este paso depende de vosotros, teneis que buscaros un poco la vida, coger los cd con los drivers de lo que tengais o ir a la pagina del fabricante y descargarlo.
Un cd de Windows XP.
-El nlite que podeis descargar desde su pagina web http://www.nliteos.com/download.html

Vale ahora tenemos que hacer un par de cosas, os recomiendo que creis una carpeta en el escritorio y la useis como espacio de trabajo.

  1. Tenemos que copiar en el disco completo del XP a una carpeta.
  2. Descomprimimos todos los drivers y los metemos en otra carpeta.
  3. Abrimos en nlite y seleccionamos la carpeta donde hemos copiado el windows xp.
  4. Vamos a proceder a indicarle que acciones queremos hacer, vamos a Integrar controladores y a Crear una ISO autoarrancable.
  5. Ahora tenemos que insertar los controladores, seleccionaremos la carpeta donde los descomprimimos y deberian salirnos todos.
  6. Este paso es fundamental, tenemos que elegir los drivers que correspondan a nuestro hardware, es decir, puede que los que los que tengamos incluyan otras tarjetas similares, asi que deberemos escoger bien. De todos modos y si dudais escogerlos todos y asi os curais en salud, aunque esto yo no lo he probado seguramente funcione, aunque el cd ocupara mas, pero por eso no hay problema quel cd del XP ocupa menos de 600 megas.
  7. Es posible que al seleccionar los drivers os salga una pantalla en la que os pregunte en que modo quereis que se integre el conrolador, en modo regular PNP o en modo texto, seleccionar modo texto.
  8. Nos muestra un resumen con los controladores que se van a integrar.
  9. El programa integrara los drivers en el instalador.
  10. En este momento, podemos hacer varias cosas, dar nombre al cd, crear una iso(es util por si quereis guardarlo en el disco duro para usos posteriores) o grabarla directamente a cd. Personalmente os recomiendo que useis un regrabable por si os equivocais en algun paso o si algo falla no perdais un cd.

Y ya esta, cuando termine de grabar tendremos nuestro cd de windows xp, con el por fin nos detectara el disco duro, podremos instalarlo tranquilamente y ademas al haber instalado los contraladores para las demas cosas tendremos casi todo el hardware funcionando al acabar la instalacion y digo “casi” porque puede ocurrir que algo no se instale y tengamos que hacerlo manualmente, pero vaya no es lo normal aunque tampoco seria raro.

Sacado de: http://www.vicente-navarro.com/blog/

Pertenece a la seccion Manuales





158 comentarios »

  1. Carlos dice:

    Hola de nuevo.

    Al final me tengo que resignar con el Vista, no hay forma y no tengo tiempo para seguir con el tema. bueno, seguire investigando y preguntando pero mas tranquilamente, ahora ya no me urge. Ademas ya me confirmaron fuentes fiables que no va a funcionar, por lo menos de momento. Yo imagino que es lo que dices tu del driver de sonido, pero como el ordenador no es mio, no puedo tenerlo mas tiempo para hacer pruebas. Nada, que lo dejo para mas adelante!!

    gracias por todo y un saludo Paco!!!

  2. Carlos dice:

    Hola!!

    Ya imaginaba que te sonaria el archivo… nada, pues le instalare el sp3 y luego lo que si hare sera seguir el orden de ese archivo para descartar cosas, a ver si ahora con la placa bien hay suerte y funciona!!!!!, aunque ya me dijo que no me lo aseguraba……claro, no se va a mojar mas de lo necesario!!

    bueno, un saludo
    hasta pronto, ya te contare mis aventuras y desventuras con el portatil, jajajaj

    chao Paco!!

  3. Neodian dice:

    @Carlos

    No te preocupes el fichero que dices esta colgado en la web de toshiba, y sinceramente es una porqueria, por ese tipo de cosas que indicas. Yo lo he usado como guia pero no lo he seguido al 100%.

    Efectivamente si instalas el SP3 te olvidas de tener que meter todas esas actualizaciones. Y por cierto algunos drivers de la web de toshiba son bastante antiguos, lo de intel(grafica y placa base) yo me los bajo de la web de intel directamente que estan mas al dia. Lo digo porque la grafica si vas a jugar algo es interesante tenerala actualizada.

    Un saludo a ti tambien.

  4. Carlos dice:

    Hola de nuevo Paco!!

    FELIZ ANO….. 2009!!

    espero que este ano te depare muchas cosas buenas……y otras mejores!!!

    Pues no se si te acuerdas que hablamos hace algun tiempo por el tema del toshiba y el cambio a XP, te escribi el comentario numero 145 de mas arriba, bueno ese fue el primero..despues de mucho probar lo lleve al servicio tecnico y me dijeron a las 2 semanas que le habian cambiado la placa base por que estaba cascada!!! ni por asomo me pensaria que podia ser eso….y ademas siendo el equipo nuevo, pero ya ves!!.

    El tema es que le pregunte al tecnico de toshiba como podia hacer para instalar el xp y me envio un documento en el que aparecen todas las instalaciones, drivers, actualizaciones, etc que deberia hacerle para que funcionase, el tema es que me dice que debo seguir el mismo orden y por un lado aparecen al principio pues la instalacion del xp, logicamente con el sp2, un par de cosas mas y luego una serie de actualizaciones sinfin….del xp (que me imagino que sera el sp3) , luego de estas, le tengo que instalar todos los drivers del sitio oficial de toshiba, el tema es que si debo seguir el mismo orden que el ede la hoja, como se supone que debo actulizar el xp si la conexion de internet me la marca para despues de dichas actualizaciones??, creo que debe estar algo mal, no se. Te queria preguntar si todas esas actualizaciones son equivalentes al sp3 (creo que si pero no estoy seguro!), ya que si son las mismas pues perfecto. Seran unas 40 o 50 mas o menos, te queria enviar el archivo pero no se como adjuntartelo por aqui, o donde colgarlo para que lo veas. ya me diras algo….

    venga Paco, un saludo

    chao

  5. Carlos dice:

    nada seguire dandole, instalare el vista y a ver si falla tb con este. y si falla pues al servicio tecnico, sino, pues a volver a repetir la operacion. bueno ya te dire en que quedo todo

    venga Paco, un saludo

  6. Neodian dice:

    Pues ni idea Carlos, te diria que la turbo memory, pero como tu pc es amd no se que puede ser. En cuanto a lo de las actualizaciones, si ya tienes el sp3 instalado entonces ya estas cubierto para lo del audio.

  7. Carlos dice:

    Buscando buscando…encontre esto en el portatil:

    me falta un dispositivo no instalado de sistema : dispositivo de sistema desconocido
    tambien veo: en detalles pone acpi\tos6205\2&daba3ff&0

    te dice algo esto a ti??

    Gracias Paco, es uq eya no se….

  8. Carlos dice:

    HOla PAco.

    Estoy aqui probando cosas, y veo que al intentar instalar el kb 888111 me dice que es anterior y que no hace falta, ya que tengo el sp3. Puede ser que al ser un turion de amd no admita el driver?? por que en la kb888111 que me descargue pone intl.exe en parte del nombre, sera que hay otro similar para amd. A lo mejor es una chorrada lo que pregunto…pero ya no se….

    gracias paco.

    chao

  9. Carlos dice:

    Ok

    Entonces no tiene nada que ver con la chicony, ni con el SP3, simplemente crees que sera el driver de sonido del propio pc, no? puede ser que simplemente no va con XP esa tarjeta y me tengo que jod..??
    Por que eso seria un gran bajon!!!!
    Entonces probare a buscar drivers para esta tarjeta de sonido. Pero no se exactamente como ver cual es, creo que es: Codec de audio: Realtek ALC268 pero el modelo no lo se por que creo que va en la placa intgrado (bueno, logico creo en un portatil) mirare por ahi a ver…en la pagina de toshiba ya lo descargue pero es el que no funciona. Probare con otro a ver si va. O si tu sabes de algun sitio …. yo me pasare por realtek a ver que encuentro….ya te dire como se quedo el tema. De todas formas si por casualidad se te ocurre algo me gustaria que me lo dijeras, Gracias Paco un saludo.

  10. Neodian dice:

    @Carlos

    Como te dije antes aunque te funcione no te va a aperecer en el administrador de dispositivos, aunque donde dices tu, en las propiedades del sonido ahi si deberia figurar.

    La verdad es que no se muy bien como ayurdarte. Pero lo que se hace en estos casos es probar con los drivers de otros modelos que tengan una tarjeta igual o similar a la tuya. O busca directamente el driver en la web del fabricante, que suelen estar mas actualizados que los de toshiba.

  11. Carlos dice:

    HoLA Paco

    Desinstale el driver de sonido, reinicie e instale el SP3, reinicie de nuevo y me puse a probar posibles configuraciones a ver si por alguna remota posibilidad tenia suerte…pero nada, no hay forma.

    Me aparece con el interrogante amarillo en dispositivos de sistema un amigo que se llama “dispositivo desconocido”, y digo yo que sera eso lo que lo fastidia. Puede ser que este haciendo algo mal? o que el driver no es el que debo poner, aunque lo descargue de la pagina de toshiba, deberia servir para este modelo de pc. Bueno no se.

    No tengo ni idea, los sonidos de windows funcionan, pero en propiedades de sonido en voz aparece propiedades avanzadas desmarcado, como si no reconociese el micro. Puede ser que tenga que ponerle otro driver distinto? ….

  12. Carlos dice:

    Hola de nuevo Paco

    Increible velocidad de respuesta, la verdad es que creia que tardarias mas en responder, asi da gusto!!! muchas gracias.

    Si, tengo el dvd para restaurar el sistema pero con vista. Por eso no me vale de mucho. Prefiero el XP. En principio el problema de drivers en general en XP lo solucione con los de la propia pagina de toshiba. Y no se por que, el micro que trae incorporado en pantalla, no va, no se si es cosa de drivers, por que si conecto un micro externo graba y el sonido lo escucho sin problema. tengo que seguir probando cosas…Voy a hacer lo que me dices del SP3 y te comento a ver si con eso puede valer.

    Otra cosa, si creo el cd/dvd de tu tutorial, y le meto todos los drivers, crees que quedara algo sin instalar y tendre que ponerlo directamente o generalmente queda listo?? lei mas arriba que a veces pasaba pero no se si es cosa de algun equipo en concreto o puede ocurrir a veces sin mas. Realmente te lo pregunto, para intentar dejarle listo al dueno del pc el cd por si tiene que formatear o algo y yo estoy de viaje, pues que lo pueda hacer el solo y de forma sencilla, los conocimientos que tiene son basicos, por eso.. (bueno, igual que los mios, si no en vez de preguntar aqui, estaria respondiendo jajaja!!!)

    te pongo este enlace del pc , si necesitas algun dato mas dimelo. que te lo doy lo antes posible!!

    http://es.computers.toshiba-europe.com/innovation/jsp/SUPPORTSECTION/discontinuedProductPage.do?service=ES&toshibaShop=false&com.broadvision.session.new=Yes&PRODUCT_ID=137397

    http://www.swoopo.es/subasta/toshiba-satellite-a210-158-portatil-15-4/69002.html

    espero que te sirvan.

    Un Saludo

  13. Neodian dice:

    @Carlos

    En primer lugar decirte que aunque hayas formateado el equipo lo mas probable es que tengas un dvd de recuperacion con el que podras poner el equipo como te vino de fabrica con todo funcionando. Eso que lo sepas.

    En cuanto al micro varias cosas, no es dispositivo, es decir, no vas a verlo en el “administrador de dispositivos” funcione o no, y otro detalle, la configuracion del sonido en realidad es lo de menos, si no funciona es problema de drivers, seguramente del de sonido, no se si el de la webcam influira en algo.

    Estaria bien que nos pasaras un enlace a las caracterisiticas tecnicas del pc, asi te podriamos ayudar mejor. Para empezar y por si acaso tiene algo que ver con los parches de xp instalate el SP3.

    Un saludo.

  14. Carlos dice:

    HOla buenas Paco y amigos en general!!!

    Me llevo leido todos vuestros comentarios y realmente necesito pedir ayudaaaaaaaaa

    Tengo un toshiba satellite a210-158 fge…. que tenia el Vista y le instale el XP, como no!!!
    Pues resulta que empezaron los problemas, que si la grafica, que si internet….bueno no me lio, empezaron los problemas que todos conocemos. Gracias a mucho mirar en internet y la pagina de toshiba consegui arreglar todos menos el que me parecia insignificante. LA CHICONI. Resulta que me va todo OK menos el audio de entrada por el micro integrado de la pantalla. Puedo grabar audio conectando un micro externo, pero cuando lo quito y pruebo con la de la web ya no me deja. No se si es la chicony, que la debo cambiar por otro software, o si son las actulizaciones de microsoft para xp que comentas mas arriba o que lo tengo mal configurado (que lo dudo) ya le di mil vueltas a las propiedades de audio. Para el pc es como que no existe ese micro. Es algo muy raro. Claro llamo a sat de toshiba y te calzan la pregunta del millon…con vista funcionaba todo?? y cuando le dices que si, no te da tiempo a llegar a PERO. …ya te dicen que “lo siento senor, en ese caso no le puedo ayudar, buenos dias!!!!”PERO deberia funcionar en xp!!

    No se Paco, se te ocurreo algo sobre el tema o necesitas algun dato que te pueda dar un pista sobre esto?. Ya me descargue todos los drivers (excepto os) y se los puse, todo bien menos eso.
    Y digo que es mi PC, pero es mentira, es el de mi padre, un regalo de hace 3 o 4 meses, y desde entonces como el vista era algo lio para el decidi meterle el XP. Y si lo llego a saber……..
    Por eso que llevo tanto tiempo intentando arreglar esto que ya es como mio, claro y el dueno pensando que estoy al despiste!!!! jajajaja.
    me podeis ayudar???
    Muchas Gracias Chicos…

  15. Neodian dice:

    @tedeza

    Olvidate de itegrar ejecutables, esos esperas y los instalas una vez que tienes el xp funcionando.

    De todos modos estuve mirando en la pagina de toshiba y buscando un poco en internet y nada. Asi que la unica solucion que veo es que cojas las especificaciones tecnicas y vayas una a una por las paginas web de los fabricantes bajandote los drivers correspondientes a tu hardware, es tedioso pero es lo que hay.

    Un saludo y suerte.

  16. tedeza dice:

    Hola, el articulo genial y muy muy clarito, pude downgradear mi portatil sin problemas.

    Y aun asi me estoy volviendo totalmente loca tratando de downgradear el Toshiba Satellite L350D que le acabo de comprar a mi madre, puesto que tiene AMD en lugar de Intel, me estoy volviendo majara para encontrar los drivers de la placa base y del procesador y me da miedo formatear y no encontrarlos.

    Tambien me ha ocurrido que muchos de los drivers que he conseguido sueltos son ehjecutables, y claro, no me los reconoce el enlite, alguien sabe si se puede extraer lainformacion de un ejecutable sin instalarlo? He probado ejecutandolos en mi otro ordenador, pero claro, no hay manera…. Ah, y por si alguien tiene este modelo, tiene los mismos componentes (MAS O MENOS, FIJARSE BIEN) que el L350 (solo que el L350 es Intel) y Toshiba si que ofrece los drivers para XP del 350, mientras que no del 350D.

    Creo que eso es todo, no se si la gente que tiene ADM ha obtenido alguna solucion… Yo lo mas que he encontrado en la web de ADM es el driver para la Tarjeta Grafica.

    Por si alguien puede ayudarme, dejo los datos del ordenador:
    – Toshiba Satellite L350D P-10
    – PRocesador: Mobile DualCore AMD Turion 64 X2 TL-60 . Placa Base: ME dice solo ATI Corp. Pero el propio programa al iniciarse dice que no es compatible del todo con mi placa base y la nombra como “ATI RS690″.
    – RAM: Hyundai HYMP 112564CP6-5
    – Controlador Grafico: ATI RADEON X700

    Gracias por la info y a ver si alguien puede ayudarme.

  17. Neodian dice:

    @marco y raul

    Como vereis el articulo no esta relacionado en absoluto con vuestra pregunta, y vuestros comentarios hacen referencia a un portatil con el que solo Orlando os puede ayudar, si quereis os puedo enviar via email su direccion de correo electronico para que os pongais en contacto.

    Un saludo

  18. raul dice:

    senores buenas tardes , aki saludandolos y esperando q alguien me pueda ayudar , justo como dice marco me pasa a mi con una maquina del mismo modelo , la formatie y utilize los discos originales del windows vista , segun la maquina el controlador es el adecuado y el dispositivo esta funcionando correctamente , pero el gran problema es q no enciende la camara por mas q lo intento , ojala me puedan ayudar y enviarme algun comentario al respecto a mi correo
    lestat_tepa@hotmail.com
    gracias

Deja tu comentario



Recordad que algunos comentarios pueden ser enviados al moderador y en dicho caso no seran publicados inmediatamente, si os pasa esto por favor sed pacientes y no volvais a comentar lo mismo, gracias.